Which devices are supported?

Blink apps require devices to have a current version of iOS, Android, or Fire OS. Your device manufacturer decides which products can be updated to the latest version of an operating system.

After Blink app version 6.1.4, some mobile devices are no longer compatible with new updates. If your device is iOS 12.5, Android 6.0, Fire OS 7.0 or higher, your device should be compatible. You can check the Operating System version in the System Settings of your device.

Click here to view the iPhone User Guide to learn more about which iOS versions are supported by Apple devices. If your device does not support the required Operating System version, please choose a different device to run the most current Blink app.


Operating systems Blink products support

iOS (Apple products)
All Blink iOS apps after version 6.1.4 only support iOS 12.5 or newer.
iOS 10 and iOS 11 are only compatible with Blink app 6.1.4 and older.
Android (various products)
From Blink app version 6.11.0 onward, only supports Android 6.0 or newer.
Fire OS (Amazon products)
From Blink app version 6.11.0 onward, only supports Fire OS Fire OS 7.0 or newer.


Do Operating Systems get old?

Yes they do. Vulnerabilities are often shared and exploited by those wishing to cause harm or mischief. Operating systems are updated to fix these problems and to add new device capabilities. Updating to the most recent version of your operating system is generally to your advantage.


Does Blink support older Operating Systems?

From time to time, we draw the line on supporting older versions of an operating system. Ending support for outdated versions can impact which devices run the Blink app, because mobile device manufacturers often limit which products can update to the newest operating system. That decision belongs to the operating system provider and is not in our control.




Can’t find what you’re looking for?

Contact Support